Search
 
 

Display results as :
 


Rechercher Advanced Search

Web Applications
install Joomla Wordpress Phpbb Drupal FluxBB PunBB osCommerce simple-machines MYBB moodle vBulletin Dolphin-v.7.1.1 PHPNUKE XOOPS
Services
install BorkNet Services X3 Services Anope Atheme Services Srvx IRC Srervices
IRCD
install Snircd IRCU INSPIRCD UNREAL Nefarious Bircd Bahamut Asuka Charybdis
TCL SCRIPT
TCL SCRIPT FOR EGGDROP Allprotection4.7 Antiproxy
Bots
Bots install FishBot bobot++ Eggdrop janus Omega Security Services Botnix Bopm SupyBot PyLink Hopm
Keywords

Latest topics
October 2017
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Affiliates
free forum

Affiliates
free forum


install inspircd in FreeBsd 11

View previous topic View next topic Go down

install inspircd in FreeBsd 11

Post  Chief on Sat Jul 01, 2017 11:57 pm

install inspircd in freebsd 11

the configure step1
Code:

portsnap fetch extract
cd /usr/ports/security/openssl/ && make install clean
pkg install openssl
echo 'DEFAULT_VERSIONS+=ssl=openssl' >> /etc/make.conf
pkg install  p5-Crypt-SSLeay
 pkg install autoconf
 pkg install automake
pkg install wget
pkg install git
cd /usr/ports/textproc/flex/ && make install clean
pkg install flex
cd /usr/ports/devel/byacc/ && make install clean
pkg install byacc
cd /usr/ports/devel/pcre/ && make install clean
pkg install pcre
cd /usr/ports/net/GeoIP/ && make install clean
/usr/local/bin/geoipupdate.sh
pkg install GeoIP
cd /usr/ports/security/gnutls/ && make install clean
pkg install gnutls
pkg install gcc
cpan
install IO::Socket::SSL
install Crypt::SSLeay

doint what do you see make reinstall.. when you will try install openssl and after it get Warning then before you get a message select what do you need from a codes

you get message WARNING You have security/openssl installed but do not have  DEFAULT_VERSIONS+=ssl=openssl set in your make.conf
then you have a some code for it
Code:

echo 'DEFAULT_VERSIONS+=ssl=openssl' >> /etc/make.conf
echo 'DEFAULT_VERSIONS+=ssl=openssl-devel' >> /etc/make.conf
echo 'DEFAULT_VERSIONS+=ssl=libressl' >> /etc/make.conf
echo 'DEFAULT_VERSIONS+=ssl=libressl-devel' >> /etc/make.conf
before you go to configure inspircd you need if do you want use with FTP Server then run it use with FileZilla client
Code:

echo ' ftpd_enable="YES"' >> /etc/rc.conf
service ftpd start
the configure inspircd
Code:

fetch https://github.com/inspircd/inspircd/archive/v2.0.24.tar.gz

2) Extract it
tar zxvf v2.0.24.tar.gz

3) Edit inspircd-2.0.24/make/template/main.mk
cd /home/name/inspircd-2.0.24/make/template/
nano main.mk
Change:
CXXFLAGS = -pipe -fPIC -DPIC
LDLIBS = -pthread -lstdc++
LDFLAGS =

To:
CXXFLAGS = -pipe -fPIC -DPIC -I/usr/local/include
LDLIBS = -pthread -lstdc++
LDFLAGS = -L/usr/local/lib

4) Run the configure script
cd inspircd-2.0.24
./configure --enable-extras=m_geoip.cpp
./configure
make
make install
mv aliases /home/name/inspircd-2.0.24/run/conf
 mv opers.conf.example /home/name/inspircd-2.0.24/run/conf
mv  modules.conf.example /home/name/inspircd-2.0.24/run/conf
mv inspircd.conf.example /home/name/inspircd-2.0.24/run/conf
cp  inspircd.conf.example  inspircd.conf
 cp modules.conf.example modules.conf
 cp opers.conf.example opers.conf
set this in inspircd.conf for ssl connect
Code:

<openssl certfile="conf/cert.pem" keyfile="conf/key.pem" dhfile="conf/dhparams.pem" hash="sha1">
you welcome download the config also you need install a modules
https://f2h.nana10.co.il/fwe60p54rcdi
or
https://f2h.nana10.co.il/81uwdg7zorfk
install a module in yourself Good luck
The Guide By BMT
thanks to freebsd channel in freenode about a help and About patience
thanks to my staff in mIRCx IRC
avatar
Chief
Admin

מספר הודעות : 211
Join date : 2011-12-09
מיקום : mIRCx IRC Network

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum